CODESYS - das IEC 61131-3 Programmiersystem
https://forum-de.codesys.com/

BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted
https://forum-de.codesys.com/viewtopic.php?f=6&t=5481
Seite 1 von 1

Autor:  rohde1990 [ Di Sep 19, 2017 9:40 am ]
Betreff des Beitrags:  BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Hallo,
ich habe einen BeagleBone Black über CANopen mit einer Motorsteuerung (Elmo Harmonica) verbunden. Die Motorsteuerung steuert einen Motor (Motor Power Company Tetra 56SR0.9).
Ich schaffe es mit dem SoftMotion Light Funktionsbaustein MC_MoveVelocity_SML den Motor zu bewegen, aber nach einer Weile springt der Baustein auf CommandAborted und der Motor stoppt.
Das Auslesen des CAN-Busses mit einem Oszilloskop ergab, dass das Sync-Signal vor dem Abbruch nicht mehr da ist bzw. gar nichts mehr über den Bus gesendet wird. Nach dem Abbruch wird wieder über den Bus gesendet.

Hat jemand eine Idee wodran das liegen kann? Hab ich evtl. etwas falsch konfiguriert oder liegt das an einem Geräte (z.B. dem BeagleBone)?

Im Anhang ist ein Screenshot von der Visualisierung und die Projekt-Datei.

Vielen Dank für jede Information

Dateianhänge:
Dateikommentar: Projekt-Datei
BBB - 1 Motor.zip [95 KiB]
8-mal heruntergeladen
Dateikommentar: Visualisierung mit AbortCommand
Screenshot (500).png
Screenshot (500).png [ 201.94 KiB | 156 mal betrachtet ]

Autor:  Edwin Schwellinger [ Di Sep 19, 2017 5:17 pm ]
Betreff des Beitrags:  Re: BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Hi,
für SoftMotion Light brauchst du nicht zwingend "Sync" und synchrone PDO's (im vergleich bei SoftMotion ist das wirklich ein muss!)
Sprich, schalt bitte doch mal den "Sync" im Manager ab und schau was dann passiert.
+ in den "Compiler defines" CANOPEN_DEBUG setzen und dann im Fehlerfall im SPS Logger schauen,
warum das ganze stehen bleibt. (denke das wird's dann nicht mehr - außer es sind Dinge wie Verdrahtung/Abschlusswiederstand usw...)

Grüße
Edwin

Dateianhänge:
CANopenDebug_and_check_plclog.jpg
CANopenDebug_and_check_plclog.jpg [ 539.2 KiB | 147 mal betrachtet ]

Autor:  rohde1990 [ Mi Sep 20, 2017 12:37 pm ]
Betreff des Beitrags:  Re: BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Danke für die Antwort.
Wenn ich "Sync" abschalte lässt sich der Motor gar nicht mehr starten und nach einer Weile erscheint vor der SoftMotion Light das rote Dreieck.
Das rote Dreieck erscheint aber auch nach einer Weile, wenn ich "Sync" noch angeschaltet habe und den Motor nicht starte.

Dateianhänge:
Dateikommentar: Log: Warnungen
Screenshot (508).png
Screenshot (508).png [ 359.57 KiB | 139 mal betrachtet ]
Dateikommentar: Log: Fehler
Screenshot (507).png
Screenshot (507).png [ 273.47 KiB | 139 mal betrachtet ]
Dateikommentar: Motor lässt sich nicht starten
Screenshot (506).png
Screenshot (506).png [ 316.73 KiB | 139 mal betrachtet ]

Autor:  Edwin Schwellinger [ Do Sep 21, 2017 5:24 am ]
Betreff des Beitrags:  Re: BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Hallo,
ich denke das "rote Dreieck" kommt weil der Antrieb dann plötzlich nicht mehr antwortet. (in beiden Fällen,
das der Master den Sync nicht mehr schickt kann ich mir nicht vorstellen, alternativ der Master die Telegramme nicht mehr empfängt obwohl die auf dem Bus sind)

Klar einen CAN Monitor anschließen(Peak oder was auch zur Verfügung steht würde auch Klarheit schaffen)
Auch klar wenn Sie den Sync abschalten sollten Sie auch die PDO's umstellen auf Async nur auf Änderung.

Denke aber am schnellten kommen wir weiter mit dem PLC Logger.

Also jetzt erst mal rausfinden ob alles auf dem Bus ist (klar kann immer sein das LowLevel CAN über das Linux Kernelmodul nicht an CODESYS gehen
oder eben dort verloren gehen.

Grüße
Edwin

Autor:  Edwin Schwellinger [ Do Sep 21, 2017 5:54 am ]
Betreff des Beitrags:  Re: BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Hallo nochmal,
mach doch bitte mal das Heatbeat noch weg..!



Grüße
Edwin

Dateianhänge:
MessagesLost.jpg
MessagesLost.jpg [ 33.58 KiB | 127 mal betrachtet ]

Autor:  rohde1990 [ Do Sep 21, 2017 12:25 pm ]
Betreff des Beitrags:  Re: BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Wenn ich den Heartbeat wegnehme ist das "rote Dreieck" dauerhaft da.

Im Anhang ist noch ein Screenshot von dem, was ich in diesem Fall mit dem PCAN Explorer empfangen habe.

Dateianhänge:
Fehler.png
Fehler.png [ 300.7 KiB | 120 mal betrachtet ]
PCAN.png
PCAN.png [ 65.19 KiB | 120 mal betrachtet ]

Autor:  rohde1990 [ Fr Okt 06, 2017 1:05 pm ]
Betreff des Beitrags:  Re: BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Was ich noch vergessen hab zu erwähnen, dass die MMotorsteuerung die Emergency-Botschaft 6300 sendet.
Ich konnte leider nicht herausfinden was das zu bedeuten hat.

Dateianhänge:
Screenshot (534).png
Screenshot (534).png [ 179.44 KiB | 92 mal betrachtet ]

Autor:  Edwin Schwellinger [ Fr Okt 06, 2017 1:59 pm ]
Betreff des Beitrags:  Re: BeagleBone Black: MC_MoveVelocity_SML -> CommandAborted

Hi,

also ich würde so vorgehen:
1. du nimmst den PEAK USB und machst mit Control Win (das ist die SPS die mit CODESYS mitkommt)
die Tests die du aktuell mit dem BeagleBone machst.
Damit will ich überprüfem liegts am Drive oder an der SPS.
(meine Vermutung ist ja immer noch das BBB CAN telegram zwischen Socket Treiber und IEC- also CODESYS verliert.

Damit die Control Win mit dem Peak USB CANopen machen kann musst du im CODESYSCotronl.cfg der Control Win SPS
folgende Componente einkommentieren:

[ComponentManager]
.
.
Component.6=CmpPCANBasicDrv


so in deinem Projekt mit Gerät aktualisieren im Gerätebaum auf Control WIN SPS wechseln.
(unten im Tasktray dann die SPS starten)
einloggen und dann bin ich gespannt wie das zusammen funktioniert deine lokale SPS und der Antrieb.

2. dann wieder zurück auf BBB und schauen -- (abhängig von Ergebnis aus Test1)

Grüße
Edwin

Seite 1 von 1 Alle Zeiten sind UTC
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/