CODESYS - das IEC 61131-3 Programmiersystem

Willkommen im offiziellen CODESYS - Forum von 3S-Smart Software Solutions | A member of the CODESYS Group
Deutsche Version English version russian version 
Aktuelle Zeit: So Sep 22, 2019 12:23 am

Alle Zeiten sind UTC




Ein neues Thema erstellen  Auf das Thema antworten  [ 20 Beiträge ]  Gehe zu Seite 1 2 Nächste
Autor Nachricht
BeitragVerfasst: Fr Jun 14, 2019 7:34 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
Da ich nach dem Umbau vom Raspberry Pi auf PFC 200 und unzähligen Updates immer noch das Problem habe, hier nochmal kurz die Beschreibung des Problems:

Wie schon aus dem Beitrag in dem Raspberry Bereich ( viewtopic.php?f=18&t=5486&start=15 ) bekannt habe ich seit 1,5 Jahren immer noch das Problem, das der Task "codesyscontrol" einfach beendet wird und damit auch die komplette Steuerung ausfällt.


Die Steuerung läuft ohne Auffälligkeiten manchmal 1-2 Tage, 1-2 Wochen oder sogar 1 Jahr ohne Unterbrechung.


Das Problem tritt verstärkt (innerhalb 1-2 Wochen manchmal auch schon nach 2 Tagen) auf, wenn ich die Visu 24/7 auf dem Touchpanel im Flur geöffnet lasse.


im Anhang 3 Bilder und ein Aktueller XML Log (bei funktionierender Runtime)

Ich hoffe, dass dieses Problem endlich gefunden wird.... mir gehen die Ideen aus.


Ich habe jetzt schon das Projekt einmal komplett neu Programmiert, unzählige Updates gemacht, Täglich den Log verfolgt.


Dateianhänge:
Dateikommentar: Log ende nach Ausfall
Screenshot_20190614_044322_com.teamviewer.teamviewer.market.mobile.jpg
Screenshot_20190614_044322_com.teamviewer.teamviewer.market.mobile.jpg [ 479.69 KiB | 855 mal betrachtet ]
Dateikommentar: Log Anfang nach Ausfall
Screenshot_20190614_044130_com.teamviewer.teamviewer.market.mobile.jpg
Screenshot_20190614_044130_com.teamviewer.teamviewer.market.mobile.jpg [ 609.13 KiB | 855 mal betrachtet ]
Dateikommentar: log XML im Betrieb
13062019.xml [174.66 KiB]
33-mal heruntergeladen
Dateikommentar: Taskmanager direkt nach Ausfall
2019-06-08.png
2019-06-08.png [ 93.84 KiB | 860 mal betrachtet ]
Nach oben
   
BeitragVerfasst: Sa Jun 15, 2019 4:52 am 
Offline
Site Admin

Registriert: Mo Sep 05, 2005 8:42 am
Beiträge: 3454
Hi,
ich lasse das Projekt mal auf meinem PFC laufen, schauen wir mal ob es hier auch passiert..
Grüße
Edwin


Nach oben
   
BeitragVerfasst: Sa Jun 15, 2019 9:34 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
Danke Edwin,

Ich weiß echt nicht mehr weiter.... Du müsstest am besten die ganze zeit mit dem Internet explorer die visu geöffnet lassen, dann passiert es recht häufig, oft schon nach einigen Tagen.....


Im Log findet man sehr oft "file>$PlcLogic$/$visu ...requested " dann "State Failed" leider finde ich keine Beschreibung z u den Logbuch Eintragungen....

was sagt dieser Eintrag aus?


Dateianhänge:
log.JPG
log.JPG [ 113.04 KiB | 820 mal betrachtet ]
Nach oben
   
BeitragVerfasst: So Jun 16, 2019 7:34 am 
Offline
Site Admin

Registriert: Mo Sep 05, 2005 8:42 am
Beiträge: 3454
Hi,
bei dem Projekt aus dem Link würde ich noch folgendes machen ( vielleicht hast du das ja inzwischen schon)
1. Update Device / Gerät aktualisieren mit rechtsclick im Gerätebaum
auf:
-PFC
-Ethernet Knoten
-Modbus Master
-Je Modbus Slave
und KBUS
dabei werden die Versionen der Libs aktualisiert.
Dann noch Compiler version und Visuprofil auf aktuell setzen (3.5.14.x)

kannst du mal mit dem CODESYS File Browser auf den PFC schauen ob dieses bild wirklich auf dem PFC ist?
apple-touch icon usw... das ist erst mal nicht das Absturzptoblem.. es fehlen halt die Grafiken in der Webvisu.


Grüße
Edwin


Nach oben
   
BeitragVerfasst: So Jun 16, 2019 12:06 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
hier mal das Aktuelle Projekt hochgeldaen auf Onedrive

https://1drv.ms/u/s!AnhoaKTrD95VxiJnZpInFkfW96la



Die Geräte habe ich nach jedem Update natürlich immer mit Aktualisiert...


Die Dateien befinden sich tatsächlich nicht in dem Ordner /visu …


Ich vermisse aber auch kein Grafik in der Visu, habe auch nie eine Grafik mit diesen Namen in die Visu eingefügt.

MfG
almot


Nach oben
   
BeitragVerfasst: Di Jun 18, 2019 10:22 am 
Offline
Site Admin

Registriert: Mo Sep 05, 2005 8:42 am
Beiträge: 3454
Hallo almot89,
bei mir läuft das so... bis jetzt ohne sich zu beenden. ( klar ich habe deine HW nicht .. Modbus usw)
Bisher habe ich noch in keinem deiner Logs irgend einen Absturz gesehen.
Daher schwierig - du könntest mal auf dem Windows VISU PC - der läuft ja auch vermutlich 24h ... mit putty die Runtime auf dem PFC manuell starten und dann eben so laufen lassen das man direkt in der Linux Konsole den vermeindlichen Crash sehen kann.

also mit putty auf dem PFC einloggen... dann die laufende Runtime beenden:
sudo /etc/init.d/codesyscontrol stop

dann die Runtime manuell starten mit:

cd /var/opt/codesys
sudo /opt/codesys/bin/codesyscontrol.bin -d /etc/CODESYSControl.cfg

dieses Putty (ssh client fenster) muss offen bleiben und dann wirst du den Abrsutz bzw das beenden der Runtime hoffentlich sehen.
Denke das sollte uns weiterbringen.

Grüße
Edwin


Zuletzt geändert von Edwin Schwellinger am Mi Jul 10, 2019 5:52 am, insgesamt 1-mal geändert.

Nach oben
   
BeitragVerfasst: Di Jun 18, 2019 10:10 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
okay, danke Edwin, das werde ich gleich morgen mal versuchen....

bis jetzt habe ich seit dem Beitrag hier im Forum, auch noch keine Probleme....
das komische ist ja, das es immer zu unterschiedlichen abständen und Zeiten passiert. Selbst Nachts ist das Problem schon 2-3 mal aufgetreten obwohl niemand die Visu aktiv genutzt hat.


Nach oben
   
BeitragVerfasst: Mi Jun 19, 2019 11:05 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
heute hatte ich im normalen log eine Warnung. siehe Bild


Dateianhänge:
warnung_log.JPG
warnung_log.JPG [ 15.05 KiB | 752 mal betrachtet ]
Nach oben
   
BeitragVerfasst: Do Jun 20, 2019 6:20 am 
Offline
Site Admin

Registriert: Mo Sep 05, 2005 8:42 am
Beiträge: 3454
Hi,
siehst du das im manuell gestarteten putty mehr davon?
Diese meldum kommt wenn das Log geflutet wird durch irgend eine zyklisch wiederkerendes anlegen
eines logeintrages.
Mach mal in einem 2. putty
cat /tmp/codesyscontrol.log
und dann noch
df
Die beiden Ausgaben sollte ich haben.

Grüße
Edwin


Nach oben
   
BeitragVerfasst: Fr Jun 21, 2019 10:50 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
so ich habe mal beide "mitschnitte" in eine Textdatei kopiert.

für mich als laie sieht das so aus, als fehlen sehr viele dateien..... aber die dateinamen sagen mir nichts....


seit der Aktualisierung auf 3.5.14.20 geht irgendwie meine Modbusverbindung zu IO-Broker nicht mehr...… ich warte noch ein paar tage ab, dann werde ich mal die WAGO Steuerung und Das Raspberry mit IO broker neu strarten

Gruß
almot


Dateianhänge:
log2 codesyslog.txt [102.35 KiB]
31-mal heruntergeladen
log1 codesyscontrol status.txt [31.1 KiB]
29-mal heruntergeladen
Nach oben
   
BeitragVerfasst: So Jun 23, 2019 5:41 pm 
Offline
Site Admin

Registriert: Mo Sep 05, 2005 8:42 am
Beiträge: 3454
Hi,
hm.. aber wo hat sich da die SPS beendet?
Grüße
Edwin


Nach oben
   
BeitragVerfasst: So Jun 23, 2019 6:06 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
Ne, ist bis jetzt noch kein Absturz aufgetreten, ich habe es nur mal so angehangen, weil da so viele Meldungen sind, das die Dateien nicht gefunden werden.

Gruß Almot


Nach oben
   
BeitragVerfasst: Mo Jun 24, 2019 6:08 am 
Offline
Site Admin

Registriert: Mo Sep 05, 2005 8:42 am
Beiträge: 3454
Hi,
also bei mir kommt das nicht mit den bitmaps die da angefordert werden...!
(Glaube nicht das das der Grund für den crash ist aber man sollte trotzdem mal genauer untersuchen)
Schreib doch mal einen Bugreport im CODESYS Store.

Grüße
Edwin


Nach oben
   
BeitragVerfasst: Mo Jul 01, 2019 9:44 pm 
Offline

Registriert: Sa Jun 13, 2015 2:06 am
Beiträge: 86
Hey Edwin,

bis jetzt läuft noch alles.... ohne absturz…. ob das Update von Version 3.5.14.0 auf 3.5.14.2 was gebracht hat?!…. aber es lief ja auch schonmal 385 Tage ohne Probleme und dann war die Runtime aus.....

Ich warte mal noch ein bissel, und dann melde ich mich wieder....

Ein Bug Report werde ich mal schreiben, wenn ich zeit finde.... bin grade im Baustress.....


Nach oben
   
BeitragVerfasst: Di Jul 02, 2019 5:19 am 
Offline
Site Admin

Registriert: Mo Sep 05, 2005 8:42 am
Beiträge: 3454
-> den BugReport, damit ich dann online draufschauen kann (alles stehen lassen), wenn es aufgetreten ist...
Grüße
Edwin


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 20 Beiträge ]  Gehe zu Seite 1 2 Nächste

Alle Zeiten sind UTC


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de